Cannot build iOS app because Google Maps framework

ios
google-app-engine
circle.yml

#1

I have tried to make continuous integration on https://circleci.com. I have added Google Maps framework to GitHub using https://git-lfs.github.com/. When I clone project everything works fine on my machine. When I push my code to git Circle CI starts to make a build and it fails because of:

:warning:️ ld: ignoring file /Users/distiller/iOS-TVM/Pods/GoogleMaps/Frameworks/GoogleMaps.framework/GoogleMaps, file was built for unsupported file format ( 0x76 0x65 0x72 0x73 0x69 0x6F 0x6E 0x20 0x68 0x74 0x74 0x70 0x73 0x3A 0x2F 0x2F ) which is not the architecture being linked (x86_64): /Users/distiller/iOS-TVM/Pods/GoogleMaps/Frameworks/GoogleMaps.framework/GoogleMaps

It means that it cannot detect architecture.
When I check architecture of that file on my machine I get this:

lipo -info Pods/GoogleMaps/Frameworks/GoogleMaps.framework/GoogleMaps

Architectures in the fat file: Pods/GoogleMaps/Frameworks/GoogleMaps.framework/GoogleMaps are: i386 x86_64 armv7 armv7s arm64

Google Maps SDK for iOS version: (1.13.0)


#2

I got exactly the same issue… I tried to force -arch parameter without success, even if the command works like a charm on my machine…


#3

I had this issue and realized that the remote server did not have git lfs installed, so the Google Maps SDK was never actually downloaded on it. Make sure to install git lfs on both servers (using these instructions). And then on the second server run git lfs pull to pull the 100 MB + Google Maps SDK there, too.


#4