Builds failing, Github API error for generating keys

github

#1

We are no longer able to clone our repository, though no permissions have changed for it, and attempts to create a deploy key result in the following error message:

Error: {"message":"Not Found","documentation_url":"https://developer.github.com/v3"} If we can help, contact us.


#2

This behavior has changed. It now sends me to a 404 page and I get an email telling me that my oauth token was revoked. I’ve tried clearing cookies, but it happens consistently. I tried removing and re-adding authorization for CircleCI, and it continues even now.


#3

On the same project. Looks like the ssh config is not being generated correctly. The keys we’ve uploaded are not being respected.


#4

…And now we can execute two containers in parallel, one repo is building correctly, the other always fails. Something is seriously broken here. Circle has never behaved like this before for us.


#5

The main issue appears to have been turning off builds for forks. It’s a private repo, so there were no forks to build anyway, but doing this prevented SSH keys from being pulled along, which is incredibly counterintuitive and insecure, since you’d want to disable fork builds if using custom SSH keys.


#6

Thanks for reporting this. It’s a known issue and we’re working on a fix right now.


#7

This issue has now been resolved.


#8