Build hangs on pip installing Django

When running the following step with Python dependencies installation

python3 -m venv venv
. venv/bin/activate
pip install Django==1.11.24

Pip hangs on installing Django with the following:

Collecting Django==1.11.24

Downloading https://files.pythonhosted.org/packages/3a/c1/dbd77256695f4b4e12b5d2c917a35963db11ce5df19c8ea6cd136b2ed54d/Django-1.11.24-py2.py3-none-any.whl (6.9MB)

When I have SSHed into the box and executed the pip install Django==1.11.24 command. It installed the package without any issues.

I have tried installing the newest version of Django there was no issue with it.

This was first observed on 2019-09-10 around 12:00 BST and since then it is failing on all branches for that project. Even is the build that previously passed, when rerun, fails on this step. We had couple of builds hanging on this step for 16 hours.

I created another ticket which could be related, I am running into another build error that started around the same time frame

John - can you check if the SHA of the docker image has changed from the last successful build? It will be shown in the “Spin Up Environment” step.

Also wondering if this is related to “no step output” issue for tasks that use a progress indicator (as PIP does) Steps with progress output stop running

That was reported resolved by our ops team… but maybe not. Please check the workaround in in that thread and let me know so I can escalate if needed!

1 Like

Here’s the SHA of my currently-not-working build (it’s hanging after a pip install):

circleci/python@sha256:565cb36ac521b93d321241bcefb275e9b398f1fe4dc15f567802e749ab062048 (for https://circleci.com/gh/jupyter/jupyter-book/1534)

Here’s the SHA of the last working build:

circleci/python@sha256:d8ef7696d10336c6e84dc045ccfba0d16a7dec9ffba9ae3f1a9f535637399263 (for https://circleci.com/gh/jupyter/jupyter-book/1525)

hope that helps!

I have tried changing the pip install command to

pip install ... | cat

and the build is working as expected now.
It looks like adding | cat is a workaround for all commands with progress bars.

@choldgraf Looks like image updates are not the cause, and as Komarx confirmed, this is an issue with step output. Please add the cat workaround while we investigate.

I’m using macOS executor, i see the CIRCLE_SHA1 and it has changed from the last successful build… a steps with progress out put stop running would makes sense as this has been a blocker for our CI process on the build step