Build breaks when installing Bower


#1

Hello,

All of our builds have started breaking this week because of an error that happens when installing Bower.

Here is sample output for npm install -g bower.

Here is our circle.yml.

Everything had been working well up until now. I tried rebuilding without cache with no success. I also tried SSH’ing into the boxes and installing bower using the command above and it worked fine. I also cannot reproduce the error locally.

Has anyone run into this issue?

Thanks,

Alexis


#2

Did you try pinning the Bower version to an older release?


#3

I just tried, and no luck. Here is the output.

I tried fixing the npm version too, but no luck either.


#4

You say you can install everything as expected if you SSH into the machine and run the command manually. Is that right? If so, at which point are you SSHing into the machine? Is that after all the dependencies steps have finished?

I wonder if running all other commands, like npm install, before running npm install -g might actually help.

Thanks.


#5

The bower install happens before npm install. But the builds looks fine now, strangely.

I tried installing bower locally (npm install bower) instead of globally and weirdly that seemed to fix the issue. No idea why. That revealed a legitimate issue with our go build step though, which when fixed, actually didn’t require any changed to our frontend build steps.

So I have no idea why things started acting up. We’re good now though.

Thanks!


#6