Apt-get update broken


#1

2 hours ago we started getting this errors:

W: Size of file /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-amd64_Packages.gz is not what the server reported 17042 20228
W: Size of file /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-amd64_Packages.gz is not what the server reported 4015 5082
W: Size of file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_binary-amd64_Packages.gz is not what the server reported 20387 23469
W: Size of file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_binary-amd64_Packages.gz is not what the server reported 15230 16382
W: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-trusty/main/binary-amd64/Packages  gnutls_handshake() failed: Handshake failed

E: Some index files failed to download. They have been ignored, or old ones used instead.

1st part is that package sizes are broken
2nd part, critical one is “gnutls_handshake() failed: Handshake failed”

When I try it from my laptop, it works …


#2

Can confirm, this is affecting us as well.


#3

Thanks for reporting this. It looks like a temporary issue with our ability to contact some external repos.

If you continue to see this behaviour please let us know.


#4

This issue has been confirmed as an issue with the Docker APT repository. A fix is being deployed upstream so it should be resolved in the next few hours.


#5

Is this still an issue? I’ve been getting a similar error since yesterday, but I’m not sure if it’s related:

fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Could not fetch updated apt files"}

#6

The original issues is resolved. We’d need to see some more details about the error you’re seeing. Please contact support directly to open a ticket.


#7