API not working?


#1

I’m having a really hard time getting the API to work, it keeps telling me to login

I’ve tried the following:

The only time I’ve had any luck is from a browser where I’m already logged into Circle.

Scope has been both status and all.

Am I missing something silly please?


#2

Im not seeing any issues with the API, could you try to create a new token to see if it does anything?


#3

Just did. https://circleci.com/api/v1/recent-builds?circle-token=:&limit=1 works great when it place in a browser normally, fails when I test with private browsing, aka, not logged in.

@levlaz pm’ed you the key and screen caps


#4

Sorry I was testing with curl :slight_smile:


#5

Ah, but curl doesn’t want to work for me either :-/


#6

So I solved this. (read, narrowed it down) Apparently, the api tokens created on the PROJECT page are completely ignored by the system, (unless you are already logged in, then it doesn’t care and 'just works’™

APIs created in the USER page? Work flawlessly.

So now a question: what the heck are the API Permission tokens on the project settings page for? Besides testing if you can read the docs correctly at anytime other then 5am? :smiley:


#7