Xcode 15.0.1 pod install error

I encountered a problem when building an iOS app with Xcode 15.0.1. When running the ‘pod install’ command in CircleCI, I received an error.

/Users/distiller/.rbenv/versions/3.1.4/lib/ruby/gems/3.1.0/gems/activesupport-7.1.1/lib/active_support/core_ext/array/conversions.rb:108:in <class:Array>': undefined method deprecator’ for ActiveSupport:Module (NoMethodError)

deprecate to_default_s: :to_s, deprecator: ActiveSupport.deprecator
Did you mean? deprecate_constant
from /Users/distiller/.rbenv/versions/3.1.4/lib/ruby/gems/3.1.0/gems/activesupport-7.1.1/lib/active_support/core_ext/array/conversions.rb:8:in <top (required)>' from <internal:/Users/distiller/.rbenv/versions/3.1.4/lib/ruby/3.1.0/rubygems/core_ext/kernel_require.rb>:85:in require’
from internal:/Users/distiller/.rbenv/versions/3.1.4/lib/ruby/3.1.0/rubygems/core_ext/kernel_require.rb:85:in require' from /Users/distiller/.rbenv/versions/3.1.4/lib/ruby/gems/3.1.0/gems/cocoapods-1.13.0/lib/cocoapods.rb:9:in <top (required)>’
from internal:/Users/distiller/.rbenv/versions/3.1.4/lib/ruby/3.1.0/rubygems/core_ext/kernel_require.rb:85:in require' from <internal:/Users/distiller/.rbenv/versions/3.1.4/lib/ruby/3.1.0/rubygems/core_ext/kernel_require.rb>:85:in require’
from /Users/distiller/.rbenv/versions/3.1.4/lib/ruby/gems/3.1.0/gems/cocoapods-1.13.0/bin/pod:36:in <top (required)>' from /Users/distiller/.rbenv/versions/3.1.4/bin/pod:25:in load’
from /Users/distiller/.rbenv/versions/3.1.4/bin/pod:25:in `’

The project was working fine with Xcode 15.0.0. I attempted to change the Xcode version in the ‘config.yml’ to 15.0.0, but it still used version 15.0.1.

How can I resolve this problem?

Im also experiencing this issue using xcode 14.2.0 image.
The issue is that activesupport got an update, but cocoapods did not define an explicit version as a dependency.

Cocoapods has a fix on their master branch, but have not released a new version to address it yet. Cannot post direct link as this message board does not allow it.

I have tried to define explicit versions of activesupport in my Gemfile(s), as discussed in the CircleCI github issues, but it does not fix the issue for me. Again I cannot direct link to it.

I have been running iOS builds locally using fastlane while experiencing this issue.

Check out commit hash 216478820851e7feed9fa512b8183808c57b6cb2 on cocoapods git repo

And github issue number: 12081

I think the problem is occurring because the current Xcode 15.0.1 image has a conflicting version of CocoaPods and Gems.

So, if CircleCI changes the image of the 15.0.1 environment, it may resolve this problem.

Cocoapods have released an update with the fix, try installing 1.14.2

For reference, here is the newest release with the fix (as @MHarrison mentioned):

(1.14.0 was the earliest, but I can see there was an additional bug fixed in 1.14.1)

Is this solution compatible with using the Flutter Orb to build the iOS app?

I am experiencing the same issue. Maybe the action needs to be taken on the CircleCI side?

cocoapods 1.14.2 work for me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.