[VNC][MacOS] Selenium, Appium and CircleCI

ios
selenium
vnc

#1

Hey folks!

I am trying to run a QA test automated in our iOS app, for it, I am using:

Python Selenium
Appium
appium python agent

In CircleCI MacOS I am running: build, unittests and this test with appium. But for some reason is getting a weird behavior. The app after built and start run, it get stuck …seems that because of display or memory (I am not sure) the app in the middle of the process just get kill some operations as example: Login. But the build created on CircleCI works on my machine (with the same configurations), and the build in my machine (that works here) don’t work on CircleCI machine either.

I am trying export container’s display to my env to see at least the selenium workflow (reproducing the same command in my circle.yml), but by vnc or x11vnc I am getting a screen of login only, I can’t access the display of that container with my session. I have tried everything here: https://circleci.com/docs/1.0/browser-debugging/ but nothing worked.

Did someone get it before? At least know about the Distiler password or something like that?


#2