Unable to Heroku API Key

heroku

#1

Adding a heroku api key from the account/heroku page, results in :

Error: Unknown Heroku exception. If we can help, contact us.

The api request is returning a 400 error


#2

I’m getting a similar issue when trying to set myself as a Heroku deploy user (400 status code):

{message: "Unknown Heroku exception."}

In the response headers:

X-Frame-Options: DENY

#3

I’m pretty sure this is just Heroku being down or slow.

This is how I figured it out on the 22nd when we had a couple of other complaints; indeed today, they report API issues.
https://status.heroku.com/

CC @cuthullu

(do let me know if I’m wrong though!)


#4

Hi rishimkumar – thanks for getting back to us on this – i’ve tried again this morning and looked at that link you posted, however I still have the same issue. Really strange as I have been able to do it before, I was able to do it yesterday in fact, then all of a sudden it stopped working. Interestingly my colleagues aren’t able to do it either

I’ve attached a screenshot of the behaviour – I still get the same 400 response:


#5

Hi, I have also been getting this error since yesterday evening, when trying to add a new heroku key or associate the key with my user. Heroku’s API status looks OK. Any ideas?


#6

Thanks for reporting this everyone. We’ve been able to reproduce and are investigating. We’ll update here when we know more.


#7

Any update on this? It still appears broken for me.


#8

Yeah! This has gotten some views and likes. A few paid orgs complained.

We’ll have someone look into the root cause and hope to have resolution soon. One engineer did some legwork already and it points to Heroku deprecating an API we depended on.
:build_failed:

We’ll update once we have resolution.

Thanks!


#9

We’ve applied a fix for the issue that prevented adding Heroku API keys to CircleCI. It will be fully rolled out within the next couple of hours.

Thank you for your patience while we investigated this problem.

Please let us know if the issues isn’t resolved for you after the fix has rolled out.


#10

Working fine for me. Thanks very much guys.


#11

This bug is back… the ui show’s the button being updated to empty.
In the console i see Your Heroku API key is invalid from the network request. Would probably be more helpful to show an notification on the website!


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.