[SOLVED] /bin/sh: docker-compose: not found

2.0

#1

Hi,

I’ve been trying to get a very simple setup working on circleci, and am unsure what I am doing wrong here, if anything.

version: 2
jobs:
  build:
    docker:
      - image: docker:17.03-git
    working_directory: ~/testing
    steps:
      - checkout
      - setup_remote_docker
      - run:
          name: Does docker even exist
          command: docker -v
      - run:
          name: Install docker-compose
          command: |
            set -x
            curl -L https://github.com/docker/compose/releases/download/1.12.0/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
            chmod +x /usr/local/bin/docker-compose
      - run:
          name: Start containers
          command: docker-compose up -d

That’s the entirety of the config.yml I am testing. I checked to see if docker-compose exists and has the correct permissions, and it does. Despite this it still says /bin/sh: docker-compose: not found in the last step. I tried docker-compose up in the same step as the docker-compose download, and I get the same error. I also tried /usr/local/bin/docker-compose. No dice. Any ideas? Am I doing something extremely stupid and not realizing it?


#2

Nevermind. I fixed it. Apparently docker:17.03-git is not sufficient, as it uses alpine as its base and that conflicts in quite frankly strange ways with docker-compose.


#3

So what image did you use instead?


#4

I created my own. You can find it here: https://hub.docker.com/r/moregreenhouse/tm-base/


#5

I’d like to know the solution more.
What do you mean conflicts?
And show the dockerfile of the alternative image, please?


#6

Found this issue in upsteam. Now thinking about solution in Circle.


#7