Same config works on github but not works on gitlab

I have an issue with yml config, here is my full configuration

when i tried to publish tag in Github repo, there is no issue,




however when i tried to publish tag in Gitlab repo, the pipline is no workflow

what should i do?

It will be worth you raising a support ticket for this issue so that it can be passed on to the correct internal team.

While I can not see an issue the condition processing logic used by circleci for filters is a little complex and gitlab support is the latest addition so they may have rewritten the logic and so cause a different result.

Things to test are

  • try and cause the job that depends on an update to the main branch to execute rather than those filtered by tag.

  • remove all the workflows that execute by branch filters and just see if tag based filtering then works.

The reasoning for this is that the circleci logic has (for an unknown) reason only really considered tags after branch checks. The result is a lot of posts/questions regarding issues over branches and tags.

Hi @aldinokemal,

I’m sorry you’re experiencing this issue.

We are aware of the current inability to build tags in GitLab projects, and our engineering team is working at fixing this limitation.

If you create a Support request, we can keep you informed of our progress.

Sure, I have created ticket for this 2 weeks ago, and still open