Repo.maven.apache.org certificate issues today


#1

Anyone else seeing build failures with Maven builds? It seems to be complaining that repo.maven.apache.org’s certificate doesn’t have a matching certificate name.

Could not transfer artifact org.sonatype.sisu:sisu-guice:jar:noaop:2.1.7 from/to central (https://repo.maven.apache.org/maven2): hostname in certificate didn't match: <repo.maven.apache.org> != <repo1.maven.org> OR <repo1.maven.org> -> [Help 1]

But if I connect to repo.maven.apache.org from my own machine, the certificate is valid and the name matches (repo.maven.apache.org).

Could there maybe be a CircleCI cache in the way with a certificate problem?

Using oraclejdk8, CIRCLE_BUILD_IMAGE=ubuntu-12.04.


#2

Hey, I am also having same issue. Any updates? Were you able to resolve this issue?


#3

We are seeing same issue since today morning. Things worked fine last night (@ 1 a.m this morning). The same builds that were successful last night are failing today due to the repo certificate issue. Builds done via local machine are going fine. So, looks like it’s a cert issue that needs to be fixed on CircleCI end. Can someone from Circleci team, please advice?


#4

I don’t think this is related to CircleCI. I’m getting the error locally sometimes too.

Some mirrors of repo.maven.apache.org have certs for repo.maven.apache.org, others have certs for repo1.maven.org.


#5

Yeah, this is a Maven Central issue. https://twitter.com/sonatype_ops/status/799693531371765760


#6

Interesting. I haven’t seen this issue locally at all even after removing the entire local repository to force a download. I also the same settings.xml that I use for circleci (no proxies and no repositories to force a default) and still no issues locally though it continues to fail on CircleCI. Any ideas?


#7

oh ok! Thanks for sharing


#8