Pulling microsoft/azure-cli failed

Hello everyone,

Today I tried to run a job that uses azure-cli/azure-docker as the executor, but I got the following error and could not run it.

Build-agent version 1.0.73288-e5ecd582 (2021-06-15T18:29:34+0000)
System information:
 Server Version: 19.03.13
 Storage Driver: overlay2
  Backing Filesystem: xfs
 Cgroup Driver: cgroupfs
 Kernel Version: 4.15.0-1102-aws
 Operating System: Ubuntu 18.04.5 LTS
 OSType: linux
 Architecture: x86_64

Starting container microsoft/azure-cli
Warning: No authentication provided, using CircleCI credentials for pulls from Docker Hub.
  image cache not found on this host, downloading microsoft/azure-cli

Error response from daemon: manifest for microsoft/azure-cli:latest not found: manifest unknown: manifest unknown

Referring to the following page, it seems that the azure-cli/azure-docker executor internally uses the latest of the microsoft/azure-cli image. When I tried to pull this image from the docker installed on my PC, I still could not pull it.

Looking at the microsoft/azure-cli page on dockerhub, it seems that the source of the image has been changed from dockerhub to the microsoft container registry.
This is just a guess, but I think microsoft may have removed the image from dockerhub.

Is it possible to change the azure-docker executor image source in azure-cli orb?


A new version of orb has just been released with the image source changed to Microsoft’s container registry.
Thanks to the Circle CI team for their quick response.

1 Like

Thank you for posting the solution!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.