Publishing to gh-pages does not work

github
git

#1

Hi,

I’m running into an issue with automatically publishing docs for my project. I have a bash script which generates documentation and pushes it to the gh-pages branch of my repository.

It has previously worked on CircleCI (~1-2 years ago), but when I revisited this project now, it fails to push correctly to GitHub.

I regenerated my GitHub access token and updated in the project env settings, just to be sure. When running the docs script locally, or in a isolated docker container, it works as expected, managing to push a new commit to the gh-pages branch.

What could have changed in the CircleCI environment that prevents this from working?

Did not work: https://circleci.com/gh/avaly/jsond-validator/68
Worked fine: same URL ^ but with build number 54
Docs script: https://github.com/avaly/jsond-validator/blob/master/tools/docs

I’d appreciate any pointers. Thanks!


#2

Hello @avaly,

Could you please reach out to support@circleci.com and open a support ticket?

We’ll try to straighten this out for you.

Best,
Zak


#3

@zzak, i come across the same issue.

Can you update the workaround in this topic?


#4

try add user key directly(at Project Settings/Permissions/Checkout SSH Keys)

it works for me.


#5