[Product Update] New Step Output UI

Is there a rollout delay? I’m not seeing that for my jobs yet … kinda. It seems like something is now eating ctrl-f as that no longer brings up the browser-level find, but it’s not actually opening the custom search widget. So ctrl-f, a, s, d, f ends up doing nothing, nothing, and then the S opens the CircleCI status page in a new tab :slight_smile:

I checked the browser (Chrome, Linux) development console for any errors, but nothing reported there.

Odd, it’s working on my browser…(Chrome, macOS). cmd+f brings up the custom search

There should only be a delay of a few mins for the rollout. Can you try again I guess in a couple of hours and let me know if you’re still not seeing it? If not, i’ll check with my engineering team to see what might be going on.

Actually, the search icon and functionality are now broken for the full job view page for me now too, in the same way, where ctrl-f is eaten, but doesn’t bring up the search widget. I also don’t seem to have the new UI any more though, so maybe this is a bad interaction there?

One question, is this all on the same project? The rollout is a project-based rollout so you may have some projects that are opted in to the new UI and some that are not.

If you give me a list of projects, I can add all of them in if you’d like? You can email them to sebastian @ circleci.com

This makes sense and on closer inspection matches what I’m seeing, yes.

I’m not fussed by having the new UX not available everywhere, but having ctrl-f functionally disabled in the projects that don’t have it yet is frustrating, but I understand this is a temporary situation.

That sounds like a bug that was not intended, checking in on that.

@mgabeler-lee-6rs fix for that is rolling out now. Can you try again in 30 mins or so and let me know if you’re still seeing the ctrl+f get swallowed on the old output?

Yep, still happening. Here’s a build from one of our open source repos where I can see it: https://app.circleci.com/pipelines/github/6RiverSystems/gosix/933/workflows/29dfd79f-7bbd-47e6-94df-78cf779736af/jobs/2164
A little more detail: When I first load the page, ctrl-f is not swallowed, but when I click to expand a step, or esp. if I click in the text output of a step, then it starts being swallowed. If I click outside the step, e.g. in the job header area, ctrl-f goes back to not being swallowed.

@mgabeler-lee-6rs Got it, working on it with the team. I’ll let you know when I have an update

@mgabeler-lee-6rs can you give it a shot again in a few minutes? We tried again to fix the issue you were seeing

Yep, the ctrl-f not working on projects with the older UI is fixed for me now, thanks!

1 Like

I would disagree - they do end with a new line, but it shouldn’t be a visible one, i.e., you generally don’t see

$ somecommand
here is a bunch
of output


Also, the behavior isn’t consistent in the Circle UI (i.e,. some steps have the extra trailing newline, and others don’t) or consistent with the old behavior. If the library in use was designed originally for VSCode, I think it could be a Microsoftism that it’s displaying UNIX line endings incorrectly.

To put it differently, I would argue that the display should render LF and CRLF equivalently.

I think the blank line at the end of output files is likely to be linked to the issue I raised here

Early on in the release, 24 blank lines were being appended to each output file which was reduced to the current one as a fix.

1 Like

I like the look of the new log view, and being able to see the full log is very helpful.

I previously submitted feedback that the double-click-and-drag word selection behavior is incorrect on Mac (it thinks / and : are letters, so a double-click on a file path will select the whole path, not just the single directory it does everywhere else on my computer). It’d be nice if that got fixed; I do it dozens of times a day to copy stack trace lines for failed tests, so I can open them in my editor. I’m slowed down by having to click and drag individual letters.

Then today it started displaying the text upside-down whenever I scroll or select, which is… less than helpful. I’d provide a screenshot, but I just signed up and Discuss won’t let me. This is a showstopper kind of bug; the log is now totally impossible to use for me.

(Safari 16.5 on macOS 13.4, BTW)

@TALlama Can you send a screenshot of the upside-down to sebastian@circleci.com please?

This is affecting me almost every time I view the spec log. I will email you a screenshot, @sebastian-lerner , as I just registered and am not allowed to attach files here.

Thanks please send a screenshot and a link to your pipeline via email.

@arowla please also include in your email safari version & macOS version. thanks!

Safari: Version 17.1 (19616.
MacOS: 14.1.1

Thanks @arowla , I didn’t get the screenshot. Could you send to sebastian@circleci.com please?

Also if you try to upgrade to a newer Safari version, are you still seeing the issue? on my machine I’m using Safari 17.3.1 and am not seeing the issue