Pipefail when using a forked gem

ruby

#1

I have forked a certain gem
and included this line in my gemfile:

gem 'feature', :git => "https://github.com/<my-git-account>/feature.git"

But Circle CI couldnt run the test, and instead generates this error:

#!/bin/bash -eo pipefail
bundle install --path vendor/bundle
Fetching gem metadata from http://rubygems.org/..........
Fetching https://github.com/<my-git-account>/feature.git

[!] There was an error while loading `feature.gemspec`: cannot load such file -- rake/packagetask
Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.

 #  from /home/circleci/ocm/vendor/bundle/ruby/2.3.0/bundler/gems/feature-15536c16af54/feature.gemspec:1
 #  -------------------------------------------
 >  require 'rubygems/package_task'
 #  
 #  -------------------------------------------
Exited with code 14

Do you know what could be the problem?


#2

A couple more questions for you:

  1. Does this work locally?
  2. If so, which version of ruby are you running? If no, you would probably have better luck opening a but report int he upstream repo.
  3. Which container image are you running in CI?

#3

Hi Thanks for the reply.

if i run bundle install —path vendor/bundle locally, it doesn’t work either… same error as in CI.

Here’s what we use: circleci/ruby:2.3-node-browsers