NVM installation not working due to .bashrc not working


#1

I’ve trawled through this discussion form and tried every single thing suggest by various people. No matter what I do, the following series of commands don’t work:

- run:
    command: |
      curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.33.5/install.sh | bash
      source ~/.bashrc
      nvm install v6.11.1

Things I’ve tried:

Putting the following in various sections of config.yml:

environment:
  BASH_ENV: ~/.bashrc

loading bashrc manually before every command:

source ~/.bashrc && nvm install v6.11.1

Can anyone please help me with getting this to work?


#2

I replied to your ticket, but for others having this issue,

Remember to run the 3 commands after the install that would activate it:

export NVM_DIR="$HOME/.nvm"
[ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh"  # This loads nvm
[ -s "$NVM_DIR/bash_completion" ] && \. "$NVM_DIR/bash_completion"  # This loads nvm bash_completion

#3

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.