MySQL v5.7 Docker Image Issue (October 16th, 2019)

There is an upstream issue for the MySQL Docker image that’s affecting users using the v5.7 release (i.e. circleci/mysql:5.7). More specifically, it’s pulling in a broken MySQL v5.7.28 image. You can find the Issue thread here.

Temporary Solution

Instead of using:




This will give you the second to last point release, MySQL v5.7.27, which is working in our images as well as upstream.

I’ll update this post again sometime in the future when upstream resolves the issue with the 5.7.28 release.


Upstream has fixed the issue. They should have new images within the hour which means we (CircleCI) will hopefully have new, fixed, images within 2 hours.


Probably still in process, but I see that you said it would be within 2 hours over 3 hours ago and we’re still having the issue. Figured I’d chime in.

Upstream only published about an hour ago. (

Ours is building now.

1 Like

Hi Ricardo,

Thank you for the update on this. We are using the mysql image directly (mysql:5.7) and it is still not working. Is there something that gets cached that would prevent the build from pulling in the newest build on the 5.7 tag?

The latest output from a build a couple minutes ago shows the following:

Starting container mysql:5.7
  using image mysql@sha256:84e9114d9511d380c255fbaec68ede96921c48108d6560edafa302c0e394c47f

which does not match the latest hash from

I just noticed the “Rebuild without cache” option. That worked!

It wasn’t the rebuild without cache that you did. We needed to publish new images, which just completed.

1 Like

Updated and fixed images are now published. You can resume using circleci/mysql:5.7!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.