MS-SQL Server ACCEPT_EULA not working


#1

I can’t make mssql-server work.

I’ve already tried to add environment variable on config.yml and even on CircleCI project variable.

What am I missing?

Tried using: Y; ‘Y’; yes;

Error:

The SQL Server End-User License Agreement (EULA) must be accepted before SQL

Server can start. The license terms for this product can be downloaded from

http://go.microsoft.com/fwlink/?LinkId=746388.

You can accept the EULA by specifying the --accept-eula command line option,

setting the ACCEPT_EULA environment variable, or using the mssql-conf tool.

Exited with code 1


#2

Do you have a custom command in your docker section? If not, you can do that and call the binary, specifying the flag mentioned above.


#3

Just to see if I got you right.

You’re saying to instead of use:

image: microsoft/mssql-server-linux/

Try something like

run:
name: Start MSSQL-Server
command: docker run -e ‘ACCEPT_EULA=Y’ -e ‘SA_PASSWORD=yourStrong(!)Password’ -p 1433:1433 -d microsoft/mssql-server-linux:2017-latest


#4

Yes, although I believe the command is the binary to be run inside the container, not a Docker command to run it from outside. There should be some examples on this forum.


#5

Got it. I’ve tried to find a example here but I couldn’t. I will give it a try. Thanks a lot :slight_smile:


#6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.