Jwt-2.1.0 requires ruby version >= 2.1, which is incompatible with the current version, ruby 2.0.0p648


#1

I am setting

macos: xcode: “9”

and when i try to run through

  • run: bundle check --path=vendor/bundle || bundle install --path=vendor/bundle

I get

jwt-2.1.0 requires ruby version >= 2.1, which is incompatible with the current version, ruby 2.0.0p648

while resolving dependencies. Is there a way to upgrade ruby version? I have tried some ways, like by setting:

ruby:
version: 1.9.3-p0-falcon

but nothing is working, any pointer to what can i do to make it work?


#2

I’m seeing this same issue. I tried setting my .ruby-version file to use ruby-2.4, but it doesn’t seem to have any affect. How do you get the ruby version used by bundle install to be 2.1 or greater?


#3

Hey there! The method of setting Ruby versions changed in CircleCI 2.0, and now works like this: https://circleci.com/docs/2.0/testing-ios/#custom-ruby-versions

Give that a shot!

@hbursk, are you setting the default shell as well?


#4