JVM crashes often at startup (OpenJDK Runtime Environment (8.0_171-b11))

scala
java

#1
#!/bin/bash -eo pipefail
sbt coverage test coverageReport coveralls
Getting org.scala-sbt sbt 1.1.5  (this may take some time)...
:: retrieving :: org.scala-sbt#boot-app
	confs: [default]
	76 artifacts copied, 0 already retrieved (27657kB/217ms)
Getting Scala 2.12.6 (for sbt)...
:: retrieving :: org.scala-sbt#boot-scala
	confs: [default]
	5 artifacts copied, 0 already retrieved (19632kB/81ms)
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f495e28b456, pid=304, tid=0x00007f492a06e700
#
# JRE version: OpenJDK Runtime Environment (8.0_171-b11) (build 1.8.0_171-8u171-b11-1~deb9u1-b11)
# Java VM: OpenJDK 64-Bit Server VM (25.171-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V  [libjvm.so+0x87f456]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/circleci/repo/hs_err_pid304.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#
/opt/sbt/bin/sbt-launch-lib.bash: line 58:   304 Aborted                 "$@"
Exited with code 134

How do I fix this?


#2

I’ve also been experiencing this with an elasticsearch docker image (5.6.9 and 5.4.3). Wondering how we can fix a JVM issue on circleci?

Snippet of my output

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f9f8e000456, pid=87, tid=0x00007f9ef60db700
#
# JRE version: OpenJDK Runtime Environment (8.0_171-b11) (build 1.8.0_171-8u171-b11-1~deb9u1-b11)
# Java VM: OpenJDK 64-Bit Server VM (25.171-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V  [libjvm.so+0x87f456]
#

#3

Can confirm. We are seeing the same on our Elastic Search images, causing our builds to fail randomly.


#4

I’ve been playing around with passing JVM options to the elasticsearch docker container.

version: 2

jobs:
  build:
    docker:
      - image: elasticsearch:5.6.9
        environment:
          ES_JAVA_OPTS: "-Xms1g -Xmx3g"

That sets the min and max JVM heap size to 1GB and 3GB, respectively.

The default is 2GB and 2GB.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.