Help migrating my orb to orb-tools v11


I decided to try and follow along with the orb-tools migration guide here:

and I think I might have…done something wrong.

To wit, I’ve been able to update my orb just fine with the old “[semver:minor] in commit message” style of publishing, but I figure if CircleCI is moving on from that in new orbs, I should update my current orb as well.

Unfortunately, when I tried that, the branch I pushed is failing on the publish step in the PR:

where I get:

Preparing to publish your orb.
Development release detected!

Error: Unable to publish orb: Non-nullable field was null.
Namespace 'GEOS-ESM' not found.

Exited with code exit status 255
CircleCI received exit code 255

So…yeah. Frankly, I always considered it a miracle that I got my original orb to work as it was a bit trial-and-error, but I’m learning. I did try adding a GITHUB_TOKEN per the migration guide but I don’t think this error is related to that…right?

Please let me know how I can help to figure this out.

Hello @mathomp4
I took a look into it and I think the error you are receiving appears to be accurate. From what I can tell, there is no namespace registered to GEOS-ESM

And Today I Learned, I just went to the orb registry to check it out and noticed that it does exist, but it is all lowercase, and this actually matters. I ran a query again as geos-esm and found you. Try again, but with all lowercase.

Thanks for the help @KyleTryon. That was it. My guess is that when I ran, I told it my namespace was my org name GEOS-ESM. But as you say, orb namespaces seem to all be lowercase. I edited up the yaml files, and got past this error. Had a few others after that, but I think it’s all good now.

Now I just need to buckle up my courage to press the merge button! :smiley:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.