Having trouble with Carthage dependencies

ios
carthage

#1

Just added some dependencies to my project using Carthage dependency management and CircleCI doesn’t seem to like it. Wondering if anybody else has used Carthage with CircleCI? I have tried adding pre dependency commands brew install carthage and carthage bootstrap


#2

Hey @boxenjim we were actually working with Carthage Last night :slight_smile:

Is your project public? If so, can you link to it so we can see which modules you are using.

Also, which packages are you trying to install?


#3

hey @levlaz it is not public unfortunately, I may be able to send you another public one though. I am using https://github.com/aschuch/QRCode


#4

It’s ok, could you just share your Cartfile?

@boxenjim ^^


#5
github "aschuch/QRCode"

here’s a link to the actual file http://d.pr/f/SLQm


#6

i’ve tried adding the following to the circle.yml file:

dependencies:
  pre:
    - brew install carthage
    - carthage bootstrap

i’m thinking maybe that the version of carthage with brew is broken perhaps. I have also had trouble getting carthage to build properly while using brew install carthage on my local machine, after I uninstalled it and re-installed the latest version from here: https://github.com/Carthage/Carthage/releases it worked perfectly.


#7

This is what I’ve got so far:

dependencies:
  pre:
    - brew update
    - brew upgrade
    - brew install carthage
    - carthage bootstrap --no-use-binaries
  • update brew
  • update all brew packages (including carthage if installed)
  • install carthage to the latest version
  • install all carthage dependencies (but don’t use pre-compiled binaries)

But I end up with warnings:

*** WARNING: Skipping build for "iphonesimulator" SDK because the necessary signing identity "iPhone Developer" is not installed
*** WARNING: Skipping build for "iphoneos" SDK because the necessary signing identity "iPhone Developer" is not installed

Final setup for using carthage with CircleCI:

circle.yml:

machine:
  xcode:
    version: "7.1"

dependencies:
  cache_directories:
    - certificates
    - profiles
  pre:
    - sudo gem install cert
    - cert --development --output_path certificates
    - sudo gem install sigh
    - sigh --development --output_path profiles
    - brew update
    - brew upgrade
    - brew install carthage
    - carthage bootstrap --no-use-binaries

Make sure to set the “Environment variables” in the Project Settings: DELIVER_USER must be set to your Apple ID and DELIVER_PASSWORD to the password.


#8