Gcloud docker push -- Permission Denied writing log file

docker
google-app-engine

#1

Hi,

Getting a issue when running:

/opt/google-cloud-sdk/bin/gcloud docker push gcr.io/made-xxx/$PROJECT_CODE:$CIRCLE_SHA1

The error report as below:

/opt/google-cloud-sdk/bin/gcloud docker push gcr.io/made-964/$PROJECT_CODE:$CIRCLE_SHA1
WARNING: Could not setup log file in /home/ubuntu/.config/gcloud/logs, (IOError: [Errno 13] Permission denied: ‘/home/ubuntu/.config/gcloud/logs/2016.10.14/18.16.16.232810.log’)
WARNING: The ‘–’ argument must be specified between gcloud specific args on the left and DOCKER_ARGS on the right. IMPORTANT: previously, commands allowed the omission of the --, and unparsed arguments were treated as implementation args. This usage is being deprecated and will be removed in March 2017.
This will be strictly enforced in March 2017. Use ‘gcloud beta docker’ to see new behavior.
Using ‘push gcr.io/made-964/devtasker:b1ba543f8170ad52f4fd5c0e0add4adf8f2e3d56’ for DOCKER_ARGS.
ERROR: gcloud crashed (IOError): [Errno 13] Permission denied: ‘/home/ubuntu/.config/gcloud/credentials’`


Any ideas what I can do to overcome this?


#2

What build image are you using (Ubuntu 14.04 or Ubuntu 12.04)? Any more of your circle.yml that you can provide?

Has this command worked before and is just not causing an issue or has it never worked for you?


#3