Fastlane Plugin error message: [!] xchtmlreport binary not installed!

Hello all - I’m having an issue with a Fastlane plugin when I try to run automated tests on Circle CI. The plugin is called xchtmlreport, and it basically generates an HTML representation of an Xcode log (with screenshots) for the test report. When I run the tests via Fastlane on my machine, everything works as expected. However, when I push my branch and try to run the same tests on Circle, I get the following error: [!] xchtmlreport binary not installed! https://github.com/TitouanVanBelle/XCTestHTMLReport

It seems like the plugin is being found:

The documentation for this plugin states that you can explicitly declare a path to the binary. I tried doing this, but I still got the same error. (Unless the binary is not at /usr/local/bin/xchtmlreport on the build machine? That’s the default location, so I assumed it was.)

Any help here would be greatly appreciated, even if you’ve seen this error or a similar one with a different plugin.

@ChiWhiteSox56 Welcome to the forum! :wave:

Are you installing xchtmlreport via Homebrew as well as installing the xchtmlreport fastlane plugin? Off the top of my head I don’t think xchtmlreport is installed by default in our images.

If you are not installing it, try installing it as per the docs here: https://github.com/TitouanVanBelle/XCTestHTMLReport#homebrew

Thanks!

Thanks so much for your quick reply!, @bytesguy!

I am not installing xchtmlreport via Homebrew on the image. I did that locally, so maybe this is it. I’ll try it and follow up with a response.

1 Like