Failed to upload artifacts from self-hosted runner

Hello, I am trying to troubleshoot an issue that I have uploading the log of a script that is running on my self-hosted runner. I tried by giving both the absolute path and the relative path of the log file but the upload fails after hanging for more than 15 minutes.

Uploading C:\script.log to script.log
Uploading C:\script.log (19 kB): Total size uploaded: 0 B
FAILED with error an unexpected storage error occurred (operation id: 6dc71376)

Can it be that the runner is blocked uploading the file by some policy on the company network?

I’ve just done a test using a self-hosted runner and this config.yml

version: 2.1

    machine: true
    working_directory: /tmp/CircleCI_working_directories/project_test_container
    resource_class: mycompany/basic-linux

    executor: exec_node

      - checkout

      # create some output
      - run:
          name: output
          command: ls > output.txt

      # Store test artifacts (screenshots, etc.)
      - store_artifacts:
          path: output.txt
          destination: artifacts

      - build

It worked as expected with the output.txt file being uploaded.

My runner is not limited by any firewall rules in terms of its access to the internet as it just sits behind a NAT gateway. From CircleCI’s docs, it is unclear what rules you would need to have in place if you have a fully locked-down data centre environment.

Thank you for investigating. Seems like the issue has indeed something to do with network issues…