Error Finding NPM Package


#1

Hi Circle Team,

I’m having trouble building our project and am out of ideas on how to fix it. When I build without cache(which is required to clear the cache of the scala project), the npm install fails because it can’t find a package.

  • Stack - Two Projects, Scala(SBT), Node 5.12(NPM)
  • Error Message

cd front && npm install
npm ERR! Linux 3.13.0-125-generic
npm ERR! argv “/home/ubuntu/nvm/versions/node/v5.12.0/bin/node” “/home/ubuntu/nvm/versions/node/v5.12.0/bin/npm” "install"
npm ERR! node v5.12.0
npm ERR! npm v3.8.6
npm ERR! code E404

npm ERR! 404 Not found : @naytev/draft-js-emoji-plugin
npm ERR! 404
npm ERR! 404 ‘@naytev/draft-js-emoji-plugin’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404 It was specified as a dependency of 'naytev-spark-front’
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ubuntu/spark/front/npm-debug.log

cd front && npm install returned exit code 1

Action failed: cd front && npm install

  • Actions Taken: I tried building without cache(which is where my error is from). I also tried SSHing into a build and running npm install. When I sshed into the box, the npm install worked just fine. There was no error on the package.

  • Recent Changes: No major changes besides a bunch of commits

  • Locally: All tests pass and npm install works correctly.

  • URL: https://circleci.com/gh/naytev/spark/2780

Thanks so much for your help. Let me know if you need any more information.

Mike Seid


#2

getting something similar too. A package that circle can’t find in CI but my tests work fine on my machine.


#3