Error deploying to GAE using the CircleCI documentation


#1

Hi, I’m using the Docs for deploying to Google AppEngine (https://circleci.com/docs/deploy-google-app-engine) but running into an issue.

Per the Docs I am deploying using this command:

echo $APPENGINE_PASSWORD | $HOME/appengine-java-sdk-1.9.30/bin/appcfg.sh update gae_dist/ --email=$APPENGINE_EMAIL --passin

I believe the issue might be that my $APPENGINE_PASSWORD has a " " in it…which is causing the recommended command to fail. does that sound like it could be a reasonable root cause?

Here is the output from the DEPLOYMENT phase in CCI:

echo $APPENGINE_PASSWORD | $HOME/appengine-java-sdk-1.9.30/bin/appcfg.sh update gae_dist/ --email=$APPENGINE_EMAIL --passin 
Dec 04, 2015 5:34:17 AM java.util.prefs.FileSystemPreferences$1 run 
INFO: Created user preferences directory. 
Please enter code: Either the access code is invalid or the OAuth token is revoked.Details: invalid_grant 
.[13145:13145:1204/053418:ERROR:browser_main_loop.cc(173)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
echo $APPENGINE_PASSWORD | $HOME/appengine-java-sdk-1.9.30/bin/appcfg.sh update gae_dist/ --email=$APPENGINE_EMAIL --passin returned exit code 1
Xlib: extension "RANDR" missing on display ":99". Action failed: echo $APPENGINE_PASSWORD | $HOME/appengine-java-sdk-1.9.30/bin/appcfg.sh update gae_dist/ --email=$APPENGINE_EMAIL --passin

#2

That is an interesting thought, could you try to change the password temporarily to something without a blank space to see if that makes a difference. If so, we should find a better way to handle this.


#3

I just tried this in circle with a java app and I got the same error. my password has no spaces.

Is this still possible or is this type of deploy to app engine no longer supported by google?


#4

did anyone manage to find a workaround to this?


#5

I got this sorted.
--service_account_json_key_file=key.json
include that and you’re good to go.


#6