Docker stopped pushing completely


#1

My app has completely stopped pushing to docker hub, since the issues yesterday. I know they said resolved so I waited a day before posting. I’ve tried changing all aspects of my deployment code, yet I constantly get failed builds because deployment fails.

Usually I get a:

unknown blob
Exited with code 1

But I’ve also seen it return with:

error parsing HTTP 404 response body: invalid character 'p' after top-level value: "404 page not found\n"
Exited with code 1

These are pushing to private repositories, I login, which says successful using:

docker login -u="$DOCKER_USER" -p="$DOCKER_PASS"
docker push jeronica/privaterepo

Anyone have any insight on how to resolve this? I’ve tried changing the docker hub repository, removing project/re-adding, moving the order of the workflow. Any support would be appreciated, otherwise I’ll need to migrate away from CircleCI to something that’s working.


#2

I’ve experiencing the same issue. See my issue here: Docker Hub failures

I believe there are failures between the two services currently. CircleCI’s status page indicates they’ve been having ongoing problems.


#3

I believe this to be resolved. If not, please follow up in creichert’s post that they linked.


#4