Docker gives kernel memory swappiness error without `--rm` flag

nodejs
docker

#1

I have Docker image for my server that I pull from AWS before running end-to-end tests on the frontend. I run the image with
docker run -d --name dih-api-dev --net host -e PG_URL=postgres://ubuntu:@127.0.0.1:5432/circle_test $EXTERNAL_REGISTRY-dev:latest npm start

but that gives me the error:

WARNING: Your kernel does not support memory swappiness capabilities, memory swappiness discarded.
699140c518246d8356d3655bc2fb2029c0de7efe186c737ce9bfb3310689e36c

The command works fine locally.

Based on the error message I’ve found the following solutions:

  • Removing --rm flag, but I don’t have that flag in the first place - found here
  • This guy has the same output, but just wants to supress it.
  • I do not try to create/change users like in this post

Any other suggestions? Thanks in advance.


#2

For reference:
I started looking through Docker-documentation, and found I suggestion here that suggest that I have to change boot options for the machine. As the problem was with Ubuntu 12.04, I tried changing to Ubuntu 14.04 for Cirlce, which solved the problem.


#3