Docker cannot install iputils

docker

#1

I use CircleCI 1.0, and ubuntu-14.04. I want to build a Docker image using a Dockerfile that contains:

FROM amazonlinux:latest
RUN yum -y install openssh-clients

The reason is that I need the ssh-keyscan binary. However, the installation fails with:

Failed:
iputils.x86_64 0:20121221-7.13.amzn1                                          

I’ve heard that this might happen on older Linux versions, perhaps not supporting aufs fully, and perhaps using Docker engine versions that are not stable.

Any ideas?


#2

git also requires iputils (via openssh probably), so this also fails:

FROM amazonlinux:latest
RUN yum -y install git

The smallest Dockerfile that fails is:

FROM amazonlinux:latest
RUN yum -y install iputils

The error is:

...
  Installing : iputils-20121221-7.13.amzn1.x86_64                         35/36
Error unpacking rpm package iputils-20121221-7.13.amzn1.x86_64

This works, though:

FROM centos:latest
RUN yum -y install iputils

#3

Hi Ulsaa, did you find a resolution for this issue? I face the same issue.
if I build the dockerfile locally, all is well. If I build via circleci then the package fails to install.

Thanks!
~G


#4

No, I don’t have a solution. However, if instead moving to CircleCI 2.0, it should be possible to build a custom Docker image instead of using the Ubuntu build server, thus avoiding the problem.


#5

no worries. thanks for the response!


#6

Very frustrating - would like to avoid setting up an enterprise docker hub account and fussing with custom docker images. Does anybody know why specifically it’s failing and if there is a workaround?


#7

This builds fine for me locally and in the machine executor.


#8

I’ve tried this and get errors as well… using CircleCI v2.0, could you show your config.yml file at all?


#9

@cellis: I wonder if the examples failed above because the authors did not do a repo update first. I don’t use Yum, but with Apt I always do a apt update prior to trying to install things.


#10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.