Consistent naming - resource_class and resource-class?

Jobs use resource_class to specify executor size, but the aws-ecr@7.3.0 Orb has a resource-class parameter instead. It caused me no end of confusion (as a new CircleCI user) trying to figure out what was going on and why my ECR was running as medium. I’d suggest the Orb match the other spelling, probably supporting both until some future deprecation point.