Cloning private submodules

git

#1

Can we have a canonical example of how git private submodules can be cloned in CircleCI?

I’ve tried overriding the clone with ‘–recursive’ and adding a post clone command to ‘git submodule init and update’. Both of these approaches have been tested with explicit deploy keys added to the SSH permissions and by adding a user checkout key for a user with access to the main and submodule repo.

It’s worth noting that the submodule is a fork.

We use an https:// git scheme, not a git:// one and I’ve tried all suggestions outlined in these posts:

The error returned is always:

ERROR: Repository not found.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.


#2

Did you ever find a solution to this? I’m getting these messages from NPM, but I’m assuming it’s just submodule problems on the NPM side.


#3

I’m too still getting these messages:


#4

I am getting same problem! Please help


#5

What problem are you having exactly? I doubt someone will be able to offer advice based on someone else’s statement of the problem. Take it from the top: what did you do, what config do you have, and what have you tried to fix it? Be fulsome and detailed in your questions please.

We’ll need logs from your build (with information removed for confidentiality if necessary) and real paths to things if necessary. For example, it is mentioned above someone is using the https: scheme for the submodule and not git:. What are your submodules using? Does the error stem through your own use of Git, or is this an NPM Issue?


#6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.