.circleci and yml exist but project not build

Hi there,

i get

No configuration was found in your project. Please refer to https://circleci.com/docs/2.0/ to get started with your configuration.

but both, the file and the folder are in my project integrated as you can see here:

anyone an idea?

Hello. The .circleci directory and it’ file needs to be under the root of your repository, you have it located in your AndroidDemo directory.

this was the deal but now i have the issue with

  • What went wrong: Execution failed for task ‘:app:connectedDebugAndroidTest’. > com.android.builder.testing.api.DeviceException: No connected devices!

is there any basic config for this case ?

i tried

#- run:
#name: Setup emulator
#command: sdkmanager “system-images;android-25;google_apis;arm64-v8a” && echo “no” | avdmanager create avd -n test -k “system-images;android-25;google_apis;arm64-v8a”
#- run:
#name: Launch emulator
#command: export LD_LIBRARY_PATH={ANDROID_HOME}/emulator/lib64:{ANDROID_HOME}/emulator/lib64/qt/lib && emulator64-arm -avd test -noaudio -no-boot-anim -no-window -accel auto -verbose
#background: true
#- run:
#name: Wait emulator
#command: |
# wait for it to have booted
#circle-android wait-for-boot
#unlock the emulator screen
#sleep 30
#adb shell input keyevent 82

but diddnt’T worked out

Running the emulator on CircleCI is usually sad, since it’s very slow due to not being able to run the x86 emulator. We strongly recommend using an external service like Firebase https://circleci.com/docs/2.0/language-android/#testing-with-firebase-test-lab

question, you said it is slow, https://circleci.com/gh/ManuelHunck/MT_TEST/38 this is ran before for 40 min w.o. response.

is it in general working or completly buggy?

honestly i don’t want to build all the gcloud firebasestuff around it currently so looking for this to just run :wink:

see config file:

On average it’s faster, but there’s almost no way to see why it’s failing to finish booting unless you fire up VNC over SSH and watch it https://circleci.com/docs/2.0/browser-testing/#interacting-with-the-browser-over-vnc

Getting the logs any other way is hard, but I’ve had some success SSH’ing in and running adb tofetch them as well.