Can't run selenium based test

selenium

#1

I am trying to run a selenium based test but I am getting below errors when I try to use the virtual display:

bundle exec ruby spec/features/visitors/selenium.rb
/home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:207:in ensure_xvfb_launched': Display socket is taken but lock file is missing - check the Headless troubleshooting guide (Headless::Exception) from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:195:inlaunch_xvfb’
from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:182:in block in pick_available_display' from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:178:ineach’
from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:178:in pick_available_display' from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:174:inattach_xvfb’
from /home/ubuntu/somaticweb/vendor/bundle/ruby/2.2.0/gems/headless-2.3.1/lib/headless.rb:93:in initialize' from spec/features/visitors/selenium.rb:5:innew’
from spec/features/visitors/selenium.rb:5:in setup' from spec/features/visitors/selenium.rb:16:inrun’
from spec/features/visitors/selenium.rb:43:in `’

bundle exec ruby spec/features/visitors/selenium.rb returned exit code 1


#2

Are you using our 14.04 build image?

If so, we start Xvfb as Display :99 automatically.

If that doesn’t help, can you try SSHing into a build to see if you can get some additional logging.


#3