Can't install charlock_holmes gem


#1

Here is our current circle.yml:

version: 2
jobs:
  build:
    working_directory: ~/protenders
    docker:
      - image: circleci/ruby:2.3-node-browsers
      - image: circleci/postgres:9.6-alpine
      - image: redis:latest
    steps:
      - checkout

      # Restore bundle cache
      - type: cache-restore
        key: pt-{{ checksum "Gemfile.lock" }}

      # Bundle install dependencies
      - run: bundle install --path vendor/bundle

      # Store bundle cache
      - type: cache-save
        key: pt-{{ checksum "Gemfile.lock" }}
        paths:
          - vendor/bundle

      # Database setup
      - run: bundle exec rake db:create
      - run: bundle exec rake db:schema:load

      # Run rspec in parallel
      - type: shell
        command: |
          bundle exec rspec --profile 10 \
                            --format RspecJunitFormatter \
                            --out /tmp/test-results/rspec.xml \
                            --format progress \
                            $(circleci tests glob "spec/**/*_spec.rb" | circleci tests split --split-by=timings)

      # Save artifacts
      - type: store_test_results
        path: /tmp/test-results

This generates the following error while installing the gems:

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/home/circleci/protenders/vendor/bundle/ruby/2.3.0/gems/charlock_holmes-0.7.3/ext/charlock_holmes
/usr/local/bin/ruby -r ./siteconf20170627-152-y48lb4.rb extconf.rb
checking for main() in -licui18n... no
checking for main() in -licui18n... no


***************************************************************************************
*********** icu required (brew install icu4c or apt-get install libicu-dev)
***********
***************************************************************************************

It seems however that libicu was installed by default in the base image. Any ideas?


#2

Any updates on this?


#3

@khelal I hit this issue as well, and found that you need to install ICU:

  - run:
      name: install dependencies
      command: |
        sudo apt-get install libicu-dev
        bundle install

This worked for me in getting pass the issue with getting charlock_holmes installed.


#4

Great that worked but still can’t get my build to run :frowning:
Getting quite frustrated with this app.


#5