Builds started failing with no config changes, failing to install dependencies from the browsers orb (firefox/chrome etc.)

My builds across multiple applications started failing this morning with no config changes.

Firstly it was applications that use the browser-tools orb, recently upgraded to 1.4.1:
browser-tools: circleci/browser-tools@1.4.1

The install google chrome step takes ages, and eventually fails with:

E: Failed to fetch  Connection failed [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Exited with code exit status 100
CircleCI received exit code 100

I have tried with apt-get update running before.

I have another application that does not require browsers, and this will run eventually, but it is many times slower than it was yesterday. Again, without config changes.

I also experience a build failure without a config change that might be related:

if ! test -f ~/opentelemetry-javaagent/opentelemetry-javaagent.jar ; then
  mkdir -p opentelemetry-javaagent
  wget \
    -q \
    -O opentelemetry-javaagent/opentelemetry-javaagent.jar \
  echo "1681dac7ba52de8859ef44c2295906b0038d0e6af8fc5163639492a027f24b2d  opentelemetry-javaagent/opentelemetry-javaagent.jar" | sha256sum -c
mkdir -p /tmp/workspace/javaagent
cp ~/opentelemetry-javaagent/opentelemetry-javaagent.jar /tmp/workspace/javaagent/javaagent.jar

results in:

wget: note: TLS certificate validation not implemented
wget: error getting response: Connection reset by peer

Exited with code exit status 1

@timpwbaker it appears that had an outage today which might be the cause of the download issues -

Unfortunately not. Still not fetching the dependencies. Also, github actions has worked OK this whole time.