Aws_auth doesn't see AWS_REGION

Hi. I’m trying to use aws_auth in my docker executor and I get the following error:

error authentication with ECR: MissingRegion: could not find region configuration

Here’s a snippet from my config.yml, the executor in question is amazon (I’ve made a screenshot to save yaml formatting):

I’ve started with 0 ENV vars, now I have 4 and it still doesn’t work. I have AWS_REGION env var set in my Project Settings as well.

What frustrates me the most is that aws_auth works in my other executor tester. And I don’t specify any env vars there.

Is there anything I’m doing wrong here?

I see what the problem is now. aws_auth is only useful to authenticate and pull the executor’s image and it takes the region from the AWS ECR repository. That’s why it worked with the executor that used ECR image and didn’t work with executor with CircleCI image (well it doesn’t need to, the CircleCI image is public and you can pull it without auth). My problem was that I thought that this aws_auth will allow me to pull/push ECR images in the executor’s steps.