Android dependency inferred incorrectly?

android
circle.yml

#1

Hi All,

Not sure if this IS a bug, but we have not changed our circle.yml file for a while and suddenly, a new dependency is being inferred somehow?

This seems to be an issue for gradle compileTestJava

On the last successful build, the output was:

export TERM="dumb"
if [ -e ./gradlew ]; then ./gradlew dependencies;else gradle dependencies;fi
:dependencies
------------------------------------------------------------
Root project
------------------------------------------------------------
No configurations
BUILD SUCCESSFUL
Total time: 22.759 secs

Currently it does:

FAILURE: Build failed with an exception.

* What went wrong:
Task 'compileTestJava' not found in root project 'customer-android'.

BUILD FAILED

Chinese character seems to throw off our circleci build
#2

We are experiencing the same issue. This started happening yesterday.


#3

Just noticed it an hour ago as well.


#4

Same problem here


#5

Alright well just now it seemed to pass… I’ll post again if it fails again somewhere


#6

Its on and off for me too,
2 build failed one succeeded


#7

Some of us have been able to rebuild successfully, but many are still failing. :disappointed:


#8

Yep, having the same issue. Rebuilt 3 times but haven’t been able to get it to succeed. My Builds were fine yesterday, haven’t made any changes to my circle.yml since then.


#9

same issue here. My circle.yml overrides the test task:
https://circleci.com/gh/yigit/android-priority-jobqueue/47#config

And nothing for dependencies but it is still running compileTestJava .
https://circleci.com/gh/yigit/android-priority-jobqueue/47#tests

This happened when I did re-run a successful build but now keeps happening for all.

update: I could workaround the issue by going over settings and adding a test dependency ./gradlew tasks to override the default behavior.


#10

Found the same issues on my project, no changes in the config since yesterday and even older builds are failing.


#11

Hi guys, I’m looking at this now! Sorry for the trouble.


#12

same problem for me. nothing changed in the yml file.


#13

I found out that this is because of our change. I’m now reverting the change and will be deployed to the whole infrastructure in 1 or 2h or so. Sorry about that.


#14

hey @kimh any updates on the deployment. This issue still exists for our Android builds.


#15

I just checked and still have the issue, not fixed yet.


#16

Sorry for the delay. The fix has been deployed to more than half of all machines now. So, if you tried now it will be likely succeed. Can you trie a few times?


#17

I’ve shipped the fix to all machines now. Can someone try if this is fixed?


#18

I just tried now. Issue still exists. Will keep retrying.


#19

@kimh thanks, the change seems to be working for us now.


#20

Thanks @kimh it is working for me now, thank you