Android build tools 23.0.2 not available

android

#1

I have a circle.yml file configuration for Android

dependencies: pre: - echo y | android update sdk --no-ui --all --filter extra-android-m2repository,extra-android-support,extra-google-google_play_services,extra-google-m2repository,build-tools-23.0.2,android-23 machine: environment: GRADLE_OPTS: '-Dorg.gradle.jvmargs="-Xmx1024m -XX:+HeapDumpOnOutOfMemoryError"' test: override: - ./gradlew assembleRelease - cp -r ~/Android-app/app/build/outputs $CIRCLE_ARTIFACTS

the error

Error: Ignoring unknown package filter ‘build-tools-23.0.2’

export TERM="dumb"
if [ -e ./gradlew ]; then ./gradlew dependencies;else gradle dependencies;fi
Parallel execution with configuration on demand is an incubating feature.
Build tools 23.0.2 missing. Downloading…

FAILURE: Build failed with an exception.

  • What went wrong:
    A problem occurred configuring project ‘:app’.

failed to find Build Tools revision 23.0.2

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED


#2

A) Module Settings GUI

  1. Go to Module Settings -> Press F4

  2. Select “app” under Modules

  3. Select the “Properties” tab

  4. Check the Build Tools Version values.

  5. See if you find the value “23.0.2rc3”

  6. If not go to select the maximum possible value such as “23.0.2”


#3

There is no UI on circleci

the build works fine on my machine


#4

These setting were for android designer studio .


#5

I fixed the issues this way

dependencies:
  pre:
    - echo y | android update sdk --no-ui --all --filter tool,extra-android-m2repository,extra-android-support,extra-google-google_play_services,extra-google-m2repository,android-23
    - echo y | android update sdk --no-ui --all --filter build-tools-23.0.2

#6

The first line, “–filter tool,” should be “–filter tools,”, see here -

id: 1 or "tools"
Type: Tool
Desc: Android SDK Tools, revision 24.4.1

Probably not a big deal, but if you happened to be relying on this for an updated tools version you might be in trouble.


#7

It looks like the key is installing tools first before installing build-tools-23.0.2. Details here.


#8

Still does not work. Tried @frank solution with no success.
Can someone upload correct circle.yml with build-tools-23.0.2?


#9

@IlyaEremin Are you referring to this? It’s definitely still working for me. Can you share your circle.yml?


#10

Yeap, I tried this link. My circle.yml

machine:
   environment:
     ANDROID_HOME: /usr/local/android-sdk-linux

dependencies:
  pre:
    - echo y | android update sdk --no-ui --all --filter "tools,platform-tools,android-23"
    - echo y | android update sdk --no-ui --all --filter "build-tools-23.0.2"


test:
  override:
    - ./gradlew build check

#11

woops, seems to work now. Thanks!
This is offtopic, but how can set up environment variable like JAVA8_HOME to jdk8? I found list of all jdk, but I cant find their paths.


#12

You can try doing an SSH build to figure out the exact path, and then use the machine: environment section in your circle.yml to set the variable to the right value.


#13