Xcode 11.3.1 Released

I’ve just released an image with Xcode 11.3.1 (build 11C505). You can select it as follows:

jobs:
  build:
    macos:
      xcode: 11.3.1

Changes from the 11.3 image:

  • Xcode is 11.3.1 build 11C505
  • Added Ruby 2.7.0 (in addition to 2.5, 2.6)
  • git upgraded from 2.24.1 (with git-lfs 2.8.0) to 2.25.0 (with git-lfs 2.9.2)
  • python upgraded from 3.7.5 to 3.7.6
  • nodejs upgraded from 13.3 to 13.6

The full manifest of software is listed here.

3 Likes

@marc I’m attempting to update to this image (from Xcode 11.0.0) but I’m hitting this error when attempting to install Bundler.

#!/bin/bash --login -eo pipefail
gem install bundler
Fetching bundler-2.1.4.gem
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.6.0 directory.

Exited with code exit status 1

Our step is defined as:

      - run:
          name: Bundler Install
          command: gem install bundler

It worked on the Xcode 11.0.0 image. I’m guessing this has something to do with the Ruby changes between 11.3.1 and 11.0.0? Any tips on migration? Our .ruby-version is 2.5.5.

@robmaceachern Hi Rob, I would suggest switching to one of the included Ruby versions, rather than the system Ruby. The system Ruby gems are installed in /Library/Ruby/Gems/2.6.0 and this directory tends to have more restrictive permissions (you may have to use sudo for example).

Try setting your Ruby version to one of the versions we make available to Chruby:

run:
    name: Set Ruby Version
    command: echo 'chruby ruby-2.5' >> ~/.bash_profile

With Chruby, gems will be installed in ~/.gem/ruby/2.x.x/gems which, as it is in the user’s own directory does not have restricted permissions.

For more info, please refer to: https://circleci.com/docs/2.0/testing-ios/#using-custom-ruby-versions

Hope this helps!

Thanks @bytesguy.

The version of Ruby we were using (0.5.5) was included on the Xcode 11.0.0 image but it took a while for me to find that it had been changed to 0.5.7 on the latest image. We also re-enabled Ruby autoswitching with the step in this post.

Hi @robmaceachern Glad you now have this resolved :slight_smile: