Workflows operational on some branches only

workflow

#1

Hi there,
I’m trying to move over to the new workflows feature with the 2.0 release. But I have hit an interesting problem I hope you can shed light on. Effectively it seems that CircleCI will not invoke work flows on my master branch. It works on other non master branches (like say “next” branch) but master always seems to look for the build step and invoke it only (the traditional way CCI worked before the work flows features was introduced). I have double and triple checked the settings and nothing seems to stand out. I originally thought this may be some state bug in CCI so I renamed my original “build” job to “install_and_build”. Workflows all work in next but definitely don’t work in master. Please advise. The group is “airfordable”. Project is “af-data-models”. TIA.


#2

Well… further testing shows this extends beyond just the master branch. I pushed to a new branch called “release” and experienced the same issue. So it would seem that CCI is reading a config somewhere and marking my “next” branch as the only one where workflows should operate. Is this possibly related to the “Main Branch” setting in BitBucket? I do have that set to point to “next” branch because its the main branch we develop on (but we treat master as the always stable branch where we tag and do our releases). I tried fiddling with that setting and no go I’m afraid :frowning:


#3

Hey @CircleCI,
Any thoughts on this one. Would love to help debug further but have not heard anything from you all yet and have had to rip out all of the Workflow work until this gets fixed. That was no fun :(. Please lets work on getting this solved.


#4

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.