Workflows filtered git tag versions not works

I’m trying to run a workflow for versions tags only but they are not running.
Here is my full config.yaml

relevant part:

deploy:
    jobs:
      - checkout_code:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
      -
        validate-git-tag-version:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - checkout_code
      -
        install_npm_deps:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - validate-git-tag-version
            - checkout_code
      -
        build:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - install_npm_deps
      -
        npm-publish:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - build
      -
        pack:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - build
      -
        github-release:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - pack
      -
        build-rpm:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - pack
      -
        build-debian:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - pack
        publish_to_jfrog:
          filters:
            # ignore any commit on any branch by default
            branches:
              ignore: /.*/
            # only act on version tags
            tags:
              only: /^v[0-9]+(\.[0-9]+)*$/
          requires:
            - build-debian
            - build-rpm

Well, not sure if it is the case but I think by ignoring all branches you are killing the tags. Can you try to allow a target branch?, I think there may be a logic block there.

At a 2nd glance it may be something less complex, I just noticed you have checkout_code as the job, if not mistaken it should be just checkout, You can try that as well

@maxleonca
Thanks for your help.
All the docs and issues around this I found tell to add the filter branches otherwise it will run for each branch because branches are enabled by default.
There is also issues about making them black list rather than white list to make it work.
Here for example:


and once he added the branches to ignore it worked:

Regarding checkout_code, I’ll check it, but I use the checkout_code for years in all my workflows and it works as expected. I don’t think that what make it not even triggered.

Any other ideas?
Thanks.

Ok, I found the issue.
It will only appear here:
https://circleci.com/gh/teambit/workflows/bit
and not here:
https://circleci.com/gh/teambit/workflows/bit/tree/master

Only on the project workflows and not in the master branch workflows.
This is very confusing!
It isn’t mentioned in the docs, and there is no convenient way to get this page from the ui, since clicking on workflows will always send you to the branches workflows.