Why circleci/ruby:2.4 installs Ruby 2.4.1?

ruby

#1

Why circleci/ruby:2.4 installs Ruby 2.4.1? Does 2.4 means 2.4.x? How to install Ruby 2.4.0?

Using: image: circleci/ruby:2.4

I’m getting error: Your Ruby version is 2.4.1, but your Gemfile specified 2.4.0

Thanks


#2

Thanks for reporting this - I’ve opened an issue on our images repo and we’ll look into it as soon as we can.

In the meantime, are you able to upgrade your dependencies to 2.4.1? This should be backwards compatible.


#3

Maybe this help to your team:

Starting container circleci/ruby:2.4.0
  image cache not found on this host, downloading circleci/ruby:2.4.0
Error response from daemon: manifest for circleci/ruby:2.4.0 not found

Unfortunately I’m PHP developer and I just need to run this Ruby project on CircleCI, nothing more.


#4

Hi there! I’ll add a +1 to this topic. Trying to install circle/ruby:2.3.0 but it jumps to the next available version that in this particular case is 2.3.4 as seen in this list.

Currently being constrained by AWS ElasticBeanstalk ruby version, that is 2.3.0 and cannot update myself to 2.3.4

Any updates on this matter?
Thanks :slight_smile:


#5

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.