Why an old version of Node.js by default?

nodejs

#1

CircleCI uses Node.js version 0.10.33 by default which is two major versions behind the current stable release (4.2.4 LTS). I know I can override which version of Node is used in my build but I just want it to use the latest stable version without having to update it as the stable version changes over time.

Why is the default so old?


#2

Thank you for pointing this out. We’ll see what we can do about this.


#3

Thanks. What have you figured out?


#4