What changed in the ruby image?

build-image
ruby
docker

#1

HI there,
Was there any change in the past month or so to circleci/ruby:2.3.4-node-browsers I should care about?
I mean, I built for almost two months a Rails app using that image and everything was working fine.
After a month or so without new commits, last Friday I did a push and the built is broken (also master which passed last time around is broken). I have re-tried several times but same outcome. I have tried to debug via ssh and it seems to me there are some issues reaching the DB (user is not created on feature specs).

Here my full config file

version: 2
jobs:
  build:
    working_directory: ~/gatekeeper
    docker:
      - image: circleci/ruby:2.3.4-node-browsers
      - image: circleci/postgres:9.6.3-alpine
    environment:
      TZ:         "/usr/share/zoneinfo/Europe/Rome"
      RAILS_ENV:  test
    steps:
      - checkout

      # Restore bundle cache
      - type: cache-restore
        key: gatekeeper-{{ checksum "Gemfile.lock" }}

      # Bundle install dependencies
      - run: bundle install --path vendor/bundle

      # Store bundle cache
      - type: cache-save
        key: gatekeeper-{{ checksum "Gemfile.lock" }}
        paths:
          - vendor/bundle

      # Copy environment variables
      - type: shell
        command: mv ~/gatekeeper/.env.sample ~/gatekeeper/.env

      # Touch RELEASE
      - type: shell
        command: touch ~/gatekeeper/RELEASE

      # Database setup
      - run: bin/rails db:create
      - run: bin/rails db:schema:load

      # Run RSpec
      - run: bin/rspec spec --fail-fast

      # Store screenshots
      - store_artifacts:
          path: tmp/capybara/

Thanks and have a nice day.


#2

Hello @sigfrid,

Thanks for writing in.

Could you send me a build link which reproduces the issue, or share a stack trace here?


#3

Hi @zzak
Thanks for looking into this issue.

You may take a look at all the builds in this tree https://circleci.com/gh/inforlife/gatekeeper/tree/test-circleci


#4

Hi @zzak
Did you have the chance to look into it?
Until the issue is not fixed we cannot ship :frowning:

Thanks


#5

@sigfrid The only thing I can think of is maybe the version of the browser changed, by looking at the build you sent me.

Sorry that is not very helpful :frowning:


#6

@zzak, Thank you for the response.

Have a good one.


#7

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.