"VM creation request returned 403" on "Spin up Environment" step


#1

Full error is

Build-agent version 0.0.3162-2e46249 (2017-04-28T17:42:07+0000)
Creating a dedicated VM
Build-agent version 0.0.3162-2e46249 (2017-04-28T17:42:07+0000)
Creating a dedicated VM
Unexpected environment preparation error: VM creation request returned 403

#2

Is that happening now…?


#3

That was the last occurrence, and hasn’t happened in the past 2 hours. It could’ve just been a blip, I guess.


#4

I’m seeing this (“VM creation request returned 403”) every now and then too on the “Setup remote Docker engine” step. It’ll still happening.

Allocating a remote Docker Engine
......
Remote Docker engine created. Using VM 'prealloc-zvrm3upo-1493829172455'
Created container accessible with:
  DOCKER_TLS_VERIFY=1
  DOCKER_HOST=tcp://104.196.121.74:2376
  DOCKER_CERT_PATH=/tmp/docker-certs031198410
  DOCKER_MACHINE_NAME=106846
Allocating a remote Docker Engine
Got error while creating host: rpc error: code = 2 desc = VM creation request returned 403

Example: https://circleci.com/gh/FB-PLP/traject/9853#tests/containers/2


#5

Escalated. Thank you for the link.


#6

Here’s another example, in case you need it:

https://circleci.com/gh/FB-PLP/traject/9860#queue-placeholder/containers/0


#7

Anddd another sample: https://circleci.com/gh/FB-PLP/traject_staging/13469#tests/containers/1

This is actually happening fairly often now. Definitely the highest source of flakiness in ours builds at the moment.

Thanks for the escalation!


#8

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.