Unexpected preparation error: Internal Error - runner failed with exit code: 126


#1

Hi all. Found the new CircleCi 2 is running well for our requirements however I keep receiving on random occasions the following error;

Unexpected preparation error: Internal Error - runner failed with exit code: 126

Has anyone else experienced this?


Docker custom image — Unexpected preparation error: Internal Error - runner failed with exit code: 126
Getting Started: Docker Engine
#2

Hi Paul, this could be a bug. Could you share a link to a build where you’re seeing this?

(You can also direct message me on this forum, though no one should be able to open your build link unless they work for us or are on your team.)


#3

Paul was seeing this: (screenshot with build details cropped)

It’s a problem with our backend. This case was a temporary error.

If you see an error like this, please create a post or let us know here.


#4

markfirmware/temperature branch circleci-2

Unexpected preparation error: Internal Error - runner failed with exit code: 126

version: 2
executorType: docker
containerInfo:
  - image: markfirmware/ufpc-do-not-use
    cmd: ["/bin/bash"]
stages:
  build:
    workDir: ~/temperature
    steps:
      - type: checkout
      - type: shell
        shell: /bin/bash
        command: echo temperature at $(date)

#5

Now working beyond my wildest expectations. I edit pascal source in the github browser and in a few seconds my docker container has compiled it, run it on qemu and uploaded screen captures to the circleci 2 artifacts. Exquisite. Could be a concurrent back-end compiler for vs code.

Mark


#6

You fully solved your error? Just making sure!


#7

Fully solved. I think you folks were improving things rapidly by Saturday morning. Intermittent issues disappeared.

Two points

  1. Poor error message if docker image is misspelled - gives authentication error

  2. circleci.yml needs a space between colon and value else failure with poor message - I can’t remember the message. I was lucky and just guessed to try a space there.

Regards,
Mark


#8

This is a yaml requirement. I typically use an online yaml parser to sanity-check a circle.yml file. A line that should be a key-value pair will get treated as a string without that space.


#9

Still getting this on a regular basis about every 3 builds :frowning:


#10

I reached out internally to find out what’s happening to your builds. I found the ones in question.


#11

Super, many thanks


#12

Hi, any further news as this is happening on around 80% of the time on current builds. Sometimes hitting rebuilds works first time, occasions today I have had to hit rebuild three times to get the build started.


#13

I haven’t heard any resolution from the team’s investigation. Last I heard they are still investigating. I will go light some fires under people to get you an answer.


#15

This costs your customers money. Call the validator. Report the correct error to the user.


#16

We are improving error messages across the board.


#17

After re-reading my post, it sounds harsh. I apologize for doing that. Mark.


#18

Are we any further with “resolving” the issue. I understand a better error message is required however the error itself needs fixing. We are finding that when doing a commit it then fails with this messages, therefore notifying a failure and someone has to go back into CircleCi and trigger the rebuild.


#19

Regarding “Internal Error … exit code 126”, we totally agree that the error needs fixing. It’s currently a high priority for our 2.0 team.


#20

Thanks Eric. Is there going to be a quicker way to whitelist new projects? I’ve sent an email to Chloe but waiting back


#21

Your org be whitelisted now–feel free to DM me with more details if that doesn’t work out.