Troubleshooting empty response

selenium

#1

I don’t know if this is the correct place to create this posts, but here we go…

I’m trying to migrate my CircleCi 1.0 setup to a 2.0 one

On both environments I have:

  • MySQL
  • PHP 7.1.9
  • Phalcon Framework 3.2.4
  • Apache
  • ChromeDriver
  • Chrome
  • Selenium Server

MySQL, PHP, Phalcon and Selenium Server have the same version on both CI environments.
ChromeDriver and Google Chrome have newer versions.
I forgot to check Apache version, but both environments have the same Apache modules enabled and use the same VirtualHost config file that I upload from my project during boot.

My config.yaml for CircleCi 2.0 uses 2 images:

  • magroski/circle-webstack:0.9
  • circleci/mysql:5.6

magroski/circle-webstack:09 is built from circleci/php:7.1.9-apache-node-browsers and the only additions are things that my CircleCi 1.0 config does during boot:

  • Phalcon installation
  • Enabling/Installing some php extensions like mailparse, gd, zip to make the image equal to my 1.0 env

The issue is: While running my acceptance tests with Codeception/Selenium I’m getting ERR_EMPTY_RESPONSE after a few requests and I have no idea of what to do. I’ve tried to use a different version of Selenium Server, but the error persists. I’ve tried to use Codeception directly with Chromedriver, but got the same results.

From my PHP logs:

  • error log is empty
  • internal log that i created doesn’t show the “erroneous” route call

From my Apache logs:

  • error log is empty
  • “erroneous” url is never called

According to Selenium logs the request is made but ERR_EMPTY_RESPONSE is returned and because I know the request is not registered on Apache logs, this means that it “died” somewhere along the road. At first I thought that maybe Apache died during the tests, but I ssh’ed into the machine and Apache is alive and well.

I also tried to curl the “erroneous” url but it is working fine.

I’ve been working on this for 4 days and I simply don’t know what else I can do or where to look.

Help?


#2

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.