Support Scala Playframework 2.5 & sbt 0.13.11 in circle

scala
sbt

#1

Playframework just released 2.5, which is supposed to be run against sbt 0.13.11.
Currently SBT is supported only up to 0.13.9 version (I tried with 0.13.11 and build failed)
Can you support 0.13.10 & 0.13.11 versions as well.

Thanks

Update:
I’ve solved this with:
override:
- echo “deb https://dl.bintray.com/sbt/debian /” | sudo tee -a /etc/apt/sources.list.d/sbt.list
- sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 642AC823
- sudo apt-get update
- sudo apt-get install sbt

Would gladly remove, this when Circle updated


#2

Hi,

Actually, according to the official docs, it supports sbt only up to 0.13.1 which dates back to three years ago.

I think it’s time circleci will support the newest version


#3